Problem with Spectrum Next emulation with CSpect

Discuss game and other programming topics not specifically covered in another forum

Moderator: Programming Moderators

PaulUK
Posts: 5
Joined: Sat Aug 22, 2020 10:22 am

Problem with Spectrum Next emulation with CSpect

Postby PaulUK » Wed Aug 26, 2020 8:24 pm

I followed the instructions from the website from the page "Creating a Z80 Assembly Development Environment on Windows". All goes well until CSpect is called and nothing happens. I triple checked the setup instructions.

I try CSpect on its own and a window opens with an audible click but is just black. This is CSpect version 2.12.34 and .36. OS is Windows 7.

I tried version 2.9.2 and it opens fine on its own but not called when I run r.bat. Possibly something to do with the Next roms? I installed the latest .Net Framework runtime and sill no luck. I hope someone can help with this issue. Thank you.

Edit: It works on Windows 10 on my works computer, just not on any of my Win7 computers. I wonder if anyone kmows of an easy fix?

User avatar
mdf200
Posts: 115
Joined: Fri Jun 02, 2017 9:52 am
Location: Dundee
Contact:

Re: Problem with Spectrum Next emulation with CSpect

Postby mdf200 » Thu Sep 17, 2020 11:09 am

Have you tried using "-tv" on the command line. This usually happens if the machine can't handle the shader, and using "-tv" disables all shader use, completely?

PaulUK
Posts: 5
Joined: Sat Aug 22, 2020 10:22 am

Re: Problem with Spectrum Next emulation with CSpect

Postby PaulUK » Thu Sep 17, 2020 11:20 am

I don't think I have, I'll try it out tonight. I simply copied the instructions as is from the article on the Spectrum Next website. I'll post here when I try it. Thank you for your suggestion, fingers crossed it works.

PaulUK
Posts: 5
Joined: Sat Aug 22, 2020 10:22 am

Re: Problem with Spectrum Next emulation with CSpect

Postby PaulUK » Thu Sep 17, 2020 6:47 pm

The -tv option worked! Well, I can now start the CSpect emulator using the tbblue.mmc and Next's ROMs. So now the emulator seems to be running fine on my old Win7 laptop. Thank you for your advice.

However I'm still having problems getting it to start when I follow the instructions here:

https://specnext.dev/tutorials/creating ... n-windows/

I wonder if theres an issue with the image file based for a 2Gb SD card?

User avatar
mdf200
Posts: 115
Joined: Fri Jun 02, 2017 9:52 am
Location: Dundee
Contact:

Re: Problem with Spectrum Next emulation with CSpect

Postby mdf200 » Thu Sep 17, 2020 7:46 pm

Just try the bigger images.... they definitely work. Remember to put the ROMs in the same folder as you put the sd card image.

PaulUK
Posts: 5
Joined: Sat Aug 22, 2020 10:22 am

Re: Problem with Spectrum Next emulation with CSpect

Postby PaulUK » Thu Sep 17, 2020 8:25 pm

mdf200 wrote:
Thu Sep 17, 2020 7:46 pm
Just try the bigger images.... they definitely work. Remember to put the ROMs in the same folder as you put the sd card image.
Im glad you mentioned that. The setup tutorial says to put the roms in the bin folder where CSpect resides. I just put the roms into the sdcard image folder and it works! I'd have never figured that out! I'm surprised no one else had this issue.
This is really great, the assembly example compiled and ran from the Next browser. Thank you so much.

User avatar
mdf200
Posts: 115
Joined: Fri Jun 02, 2017 9:52 am
Location: Dundee
Contact:

Re: Problem with Spectrum Next emulation with CSpect

Postby mdf200 » Fri Sep 18, 2020 3:55 pm

This was changed some time ago, so that there could be multiple versions of the card and ROMs. While you can rename the card image, the ROM files all have to be called the same thing, so I was constantly renaming ROM files to check different image files.

This makes it easy, create a folder for the image and the ROMs, and just point to that....


Who is online

Users browsing this forum: No registered users and 2 guests