HDMI causing background noise to sound output...

This section is for discussing everything about Next hardware and latest updates.
User avatar
MSuomi
Posts: 33
Joined: Tue May 30, 2017 6:22 am

HDMI causing background noise to sound output...

Postby MSuomi » Fri Sep 18, 2020 5:17 am

Transferred my Next to my actual computer table, to be more usable.
Noticed, that while Next is connected to my amp via 3.5" -> RCA-cable, as long as HDMI is connected there is constant "chirping" (or whatever, you know what I mean) sound coming through speakers). And this comes through, no matter which input on amp is chosen.

I believe, that the only way to get rid of this is to modify something on motherboard (like a filtering capacitor)...

Modifying isn't the problem, but I'm not an engineer ;)

Alcoholics Anonymous
Posts: 781
Joined: Mon May 29, 2017 7:00 pm

Re: HDMI causing background noise to sound output...

Postby Alcoholics Anonymous » Fri Sep 18, 2020 2:41 pm

Could you try "REG 2,128" from basic to see if it goes away?

There are two things here which may contribute to poor audio on hdmi. One is the cable is too long and/or you have something in between the computer and the tv so that it's not a direct connection.

The other is in the core version. We tried for a short time to use the full 16-bit width of hdmi audio and found out some tvs didn't generate correct audio. This is in core version 3.01.05 and is corrected in 3.01.06. If the first two above aren't the cause, a later core should be tried next.

User avatar
MSuomi
Posts: 33
Joined: Tue May 30, 2017 6:22 am

Re: HDMI causing background noise to sound output...

Postby MSuomi » Fri Sep 18, 2020 3:02 pm

Alcoholics Anonymous wrote:
Fri Sep 18, 2020 2:41 pm
Could you try "REG 2,128" from basic to see if it goes away?

There are two things here which may contribute to poor audio on hdmi. One is the cable is too long and/or you have something in between the computer and the tv so that it's not a direct connection.

The other is in the core version. We tried for a short time to use the full 16-bit width of hdmi audio and found out some tvs didn't generate correct audio. This is in core version 3.01.05 and is corrected in 3.01.06. If the first two above aren't the cause, a later core should be tried next.
I don't use HDMI-audio, I'm connecting audio with 3,5" audio out to amp RCA-audio in. And as long as there is an HDMI-cable connected to Next, the amp gets tickling sound to it.No matter what input is selected or if the Next is on or off.

Cable is high quality and short, connected to my computer monitor.

I didn't even know, there are newer cores than in the may-version, which was published in the site https://www.specnext.com/sn-1-3/
So newest are those on the GitHub, with the .fw and .tbu endings?

Alcoholics Anonymous
Posts: 781
Joined: Mon May 29, 2017 7:00 pm

Re: HDMI causing background noise to sound output...

Postby Alcoholics Anonymous » Fri Sep 18, 2020 4:59 pm

Ok it looks like I misunderstood you.
MSuomi wrote:
Fri Sep 18, 2020 3:02 pm
I didn't even know, there are newer cores than in the may-version, which was published in the site https://www.specnext.com/sn-1-3/
So newest are those on the GitHub, with the .fw and .tbu endings?
Yes the current stable development version of everything is at gitlab.

The change log for nextzxos and the change log for the core are also available.

You need to update everything, not just the core or just nextzxos as they are dependent on each other. The correct order is update the core (tbu file) then switch off and replace the rest of the files on your sd card to update nextzxos then power up. Unzipping directly to the sd card is error prone so you should unzip to the pc then copy those files to the sd card. Make a backup of your sd card on your pc in case anything needs to be recovered.

User avatar
MSuomi
Posts: 33
Joined: Tue May 30, 2017 6:22 am

Re: HDMI causing background noise to sound output...

Postby MSuomi » Fri Sep 18, 2020 5:32 pm

Alcoholics Anonymous wrote:
Fri Sep 18, 2020 4:59 pm
Ok it looks like I misunderstood you.
MSuomi wrote:
Fri Sep 18, 2020 3:02 pm
I didn't even know, there are newer cores than in the may-version, which was published in the site https://www.specnext.com/sn-1-3/
So newest are those on the GitHub, with the .fw and .tbu endings?
Yes the current stable development version of everything is at gitlab.

The change log for nextzxos and the change log for the core are also available.

You need to update everything, not just the core or just nextzxos as they are dependent on each other. The correct order is update the core (tbu file) then switch off and replace the rest of the files on your sd card to update nextzxos then power up. Unzipping directly to the sd card is error prone so you should unzip to the pc then copy those files to the sd card. Make a backup of your sd card on your pc in case anything needs to be recovered.
I have kinda always hated the way, how Linux-things are presented (and that is because I'm mainly Windows type of person). Though earlier I checked the new Linux distros about every year. I have lost the interest to play with them nowadays ;)

And GitHub is a VERY Linux style of way to present things. I would hope, there would be ONE ZIP (or package) which contains the needed things...

Anyway, I'll do just that. Not today, though ;)

Thanks for the links! I'll put them on my list to follow!

Ped7g
Posts: 256
Joined: Mon Jul 16, 2018 7:11 pm

Re: HDMI causing background noise to sound output...

Postby Ped7g » Sat Sep 19, 2020 1:21 pm

The newer core and firmware will become new zip file on the https://www.specnext.com/latestdistro/ web. The gitlab stuff is sort of "open beta" for users who are interested and more technical. For users who want to deal only with the "official distro zip" the 3.1.5 is still the latest core.

User avatar
MSuomi
Posts: 33
Joined: Tue May 30, 2017 6:22 am

Re: HDMI causing background noise to sound output...

Postby MSuomi » Sat Sep 19, 2020 9:05 pm

Ped7g wrote:
Sat Sep 19, 2020 1:21 pm
The newer core and firmware will become new zip file on the https://www.specnext.com/latestdistro/ web. The gitlab stuff is sort of "open beta" for users who are interested and more technical. For users who want to deal only with the "official distro zip" the 3.1.5 is still the latest core.
Yes, I gathered that much.
Also, I don't think any change on the FW or software will change this problem.
Anyway, one way or another, I will find a way around this problem.
Maybe I will utilize a second amp to Next or buy an amp with HDMI-inputs or any combination of things :D

Alcoholics Anonymous
Posts: 781
Joined: Mon May 29, 2017 7:00 pm

Re: HDMI causing background noise to sound output...

Postby Alcoholics Anonymous » Wed Sep 23, 2020 4:15 am

MSuomi wrote:
Fri Sep 18, 2020 5:32 pm
And GitHub is a VERY Linux style of way to present things. I would hope, there would be ONE ZIP (or package) which contains the needed things...
It's just showing files stored in a directory structure -- the same one that is on the sd card. Whether it's windows or linux, everything gets stored in directories like this.

There is a download button on the top right that looks like a down array pointing into a tray. If you press that you have the option to get a zip file and that will contain everything that should be unzipped into the root of the sd card. It's the same set of files that the next public distribution will be, although that may prune some things out to reduce size.

About your problem, it's hard to say what it is. Does it help if you physically move the speakers?

User avatar
MSuomi
Posts: 33
Joined: Tue May 30, 2017 6:22 am

Re: HDMI causing background noise to sound output...

Postby MSuomi » Mon Feb 01, 2021 4:15 pm

Just to update, found a way to "Dance around it" ;)
When I connect Next's analog audio out to my Soundblaster X6's analog input and it transfers it to amp, there is no extra noise on the sound!

Now I just have not properly working HDMI-picture to worry about ;)
My 49" Samsung CHG90 doesn't like the Next's output ;)
Setting 60Hz output and choosing 60Hz from Samsung makes it so, that it flashes black only once in about 2 minutes or so :D

User avatar
Eratosthenes
Posts: 320
Joined: Mon May 29, 2017 8:17 pm

Re: HDMI causing background noise to sound output...

Postby Eratosthenes » Mon Feb 01, 2021 4:55 pm

Hi MSuomi,

I also have sound issues when using HDMI. Even though the effect is different it may be that it's the same reason.
The effect I have is a ticking sound that occurs sometimes.

Fiddling around with different HDMI cables, CEC filters and so on I fixed it by swapping the cable. Could be a side effect of the back powering issues of the Next board.

As I'm using HDMI audio I haven't checked if it also will be available on 3.5mm out. I will check this and let you know.


Who is online

Users browsing this forum: No registered users and 6 guests